View Issue Details

IDProjectCategoryView StatusLast Update
0000507XMB1Bugspublic2018-01-18 06:09
ReporterlottosAssigned Tomiqrogroove 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.9.8 SP2 
Target Version1.9.11.15Fixed in Version1.9.11.15 
Summary0000507: 'dot' functionality missing in today.php
Descriptionforumdisplay.php has code that changes, for example, hot_folder.gif to dot_hot_folder.gif if the member has posted on that topic/thread so the member can easily identify if they posted on that topic/thread when viewing by forum category.

Part of the code that deals with this is:
if ($SETTINGS['dotfolders'] == 'on' && X_MEMBER && (count($threadsInFid) > 0) && in_array($thread['tid'], $threadsInFid)) {
        $folder = 'dot_'.$folder;
    }

however there is no corresponding code in today.php with the outcome being that a member cannot identify if they posted on a particular topic/thread when using that script.

Steps To ReproduceView a topic created by member by forumdisplay.php and functionality works.

View a topic created by member by toay.php and functionality doesn't exist.
TagsNo tags attached.
MySQL Version
PHP Version
Web Server
Browser
Flags
Original Reporter
SVN Revision2713

Activities

miqrogroove

2017-12-21 05:53

administrator   ~0000347

Patch reviewed, with problems. The new query placement should not be inside a loop. I will try to find a quick fix for this.

miqrogroove

2017-12-21 06:14

administrator   ~0000348

Looks like this can be done without a major refactor.

Issue History

Date Modified Username Field Change
2017-06-27 16:06 lottos New Issue
2017-12-20 09:02 miqrogroove Product Version 1.9.11.13 => 1.9.8 SP2
2017-12-20 09:02 miqrogroove Target Version => 1.9.11.14
2017-12-21 05:53 miqrogroove Severity tweak => minor
2017-12-21 05:53 miqrogroove Status new => confirmed
2017-12-21 05:53 miqrogroove Target Version 1.9.11.14 => 1.9.11.15
2017-12-21 05:53 miqrogroove Note Added: 0000347
2017-12-21 06:14 miqrogroove Assigned To => miqrogroove
2017-12-21 06:14 miqrogroove Status confirmed => assigned
2017-12-21 06:14 miqrogroove Note Added: 0000348
2017-12-21 07:22 miqrogroove Status assigned => resolved
2017-12-21 07:22 miqrogroove Resolution open => fixed
2017-12-21 07:22 miqrogroove Fixed in Version => 1.9.11.15
2017-12-21 07:22 miqrogroove SVN Revision => 2713
2018-01-18 06:09 miqrogroove Status resolved => closed