View Issue Details

IDProjectCategoryView StatusLast Update
0000505XMB1Bugspublic2018-01-18 06:09
ReportermiqrogrooveAssigned Tomiqrogroove 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.9.8 SP2 
Target Version1.9.11.15Fixed in Version1.9.11.15 
Summary0000505: XMB Installer Throws Deprecated Database Extension
Description[15-Mar-2017 11:48:22 America/Detroit] PHP Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in xmb/install/index.php on line 1468
TagsNo tags attached.
MySQL Version
PHP Version5.5
Web Server
Browser
Flags
Original Reporter
SVN Revision2729

Activities

Xian

2017-09-16 20:57

reporter   ~0000336

Installer (index.php) patched to include mysqli_() functions provided that the config.php $database setting is set to = 'mysqli'

Part of the 1.9.12.4.BETA package

index.php (72,737 bytes)

miqrogroove

2017-12-23 18:23

administrator   ~0000362

This issue was not addressed in 1.9.11.14.

The mysql extension was deprecated in PHP 5.5 and XMB does not handle this correctly in any version.

lottos

2017-12-24 01:41

updater   ~0000363

Could be worth having a look at http://forums.xmbforum2.com/viewthread.php?tid=777001&goto=search&pid=1375703 as there were a few issues listed on that post, one of which may touch on the installer and others that touch on other issues [such as function phpShorthandValue]

miqrogroove

2017-12-24 02:31

administrator   ~0000364

Yes I've reviewed the prior work and it only fixes PHP 7. We need to maintain compatibility with old versions so this bug has to remain open until fixed. Looks like less than a day of work.

miqrogroove

2017-12-26 07:17

administrator   ~0000367

The trunk version of the XMB installer now uses MySQLi whenever available.

Issue History

Date Modified Username Field Change
2017-03-15 19:40 miqrogroove New Issue
2017-09-16 20:57 Xian File Added: index.php
2017-09-16 20:57 Xian Note Added: 0000336
2017-12-20 07:10 miqrogroove Target Version 1.9.11.14 => 1.9.11.15
2017-12-20 08:24 miqrogroove Target Version 1.9.11.15 => 1.9.11.14
2017-12-23 18:23 miqrogroove Status new => confirmed
2017-12-23 18:23 miqrogroove Product Version => 1.9.8 SP2
2017-12-23 18:23 miqrogroove Target Version 1.9.11.14 => 1.9.11.15
2017-12-23 18:23 miqrogroove PHP Version 5.6 => 5.5
2017-12-23 18:23 miqrogroove Note Added: 0000362
2017-12-24 01:41 lottos Note Added: 0000363
2017-12-24 02:31 miqrogroove Note Added: 0000364
2017-12-25 05:13 miqrogroove Assigned To => miqrogroove
2017-12-25 05:13 miqrogroove Status confirmed => assigned
2017-12-26 07:17 miqrogroove Status assigned => resolved
2017-12-26 07:17 miqrogroove Resolution open => fixed
2017-12-26 07:17 miqrogroove Fixed in Version => 1.9.11.15
2017-12-26 07:17 miqrogroove SVN Revision => 2729
2017-12-26 07:17 miqrogroove Note Added: 0000367
2018-01-18 06:09 miqrogroove Status resolved => closed