View Issue Details

IDProjectCategoryView StatusLast Update
0000713XMB1Bugspublic2024-05-26 11:07
Reportermiqrogroove Assigned Tomiqrogroove  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.9.12 
Target Version1.9.12.07Fixed in Version1.9.12.07 
Summary0000713: Integer Width Deprecated by MySQL 8.0
DescriptionInstall and upgrade scripts do not always check MySQL warnings. The code used by include/schema.inc.php does generate the following warning that is not displayed by XMB:

"Integer display width is deprecated and will be removed in a future release."

Tested on MySQL 8.0.36.
Additional InformationSeveral portions of the upgrade script need to be revised, because the MySQL 8.0 `DESCRIBE` output has changed. XMB expects output like "smallint(6)" but the new MySQL instead shows "smallint".
TagsNo tags attached.
MySQL Version
PHP Version
Web Server
Browser
FlagsSchema Updates
Original Reporter
SVN Revision3059

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2024-05-18 05:55 miqrogroove New Issue
2024-05-18 05:57 miqrogroove Status new => confirmed
2024-05-25 08:18 miqrogroove Additional Information Updated
2024-05-25 08:18 miqrogroove MySQL Version 8.0 =>
2024-05-25 08:18 miqrogroove Flags Schema Updates => Schema Updates
2024-05-25 08:20 miqrogroove Additional Information Updated
2024-05-25 08:20 miqrogroove Flags Schema Updates => Schema Updates
2024-05-26 11:07 miqrogroove Assigned To => miqrogroove
2024-05-26 11:07 miqrogroove Status confirmed => resolved
2024-05-26 11:07 miqrogroove Resolution open => fixed
2024-05-26 11:07 miqrogroove Fixed in Version => 1.9.12.07
2024-05-26 11:07 miqrogroove Flags Schema Updates => Schema Updates
2024-05-26 11:07 miqrogroove SVN Revision => 3059