View Issue Details

IDProjectCategoryView StatusLast Update
0000342XMB1Bugspublic2010-02-24 17:57
ReportermiqrogrooveAssigned Tomiqrogroove 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Product Version1.9.11 
Target Version1.9.11.08Fixed in Version1.9.11.08 
Summary0000342: Undefined index in assertEmptyOutputStream()
DescriptionIf the script dies before loading settings, the settings indexes will be undefined and must be checked before use.

Notice: Undefined index: gzipcompress in include\global.inc.php on line 79
TagsNo tags attached.
MySQL Version
PHP Version
Web Server
Browser
Flags
Original Reporter
SVN Revision2222

Activities

2010-01-24 16:59

 

ticket-342.patch (729 bytes)
Index: global.inc.php
===================================================================
--- global.inc.php	(revision 2219)
+++ global.inc.php	(working copy)
@@ -75,8 +75,10 @@
             $buffer = ob_get_clean();
             echo 'OB:';
             var_dump(ini_get('output_buffering'));
-            echo 'GZ:';
-            var_dump($SETTINGS['gzipcompress']);
+            if (isset($SETTINGS['gzipcompress'])) {
+                echo 'GZ:';
+                var_dump($SETTINGS['gzipcompress']);
+            }
             echo "<br /><br />Error: XMB failed to start due to file corruption. "
                . "Please inspect $error_source.  It has generated the following unexpected output:$buffer";
         }
ticket-342.patch (729 bytes)

Issue History

Date Modified Username Field Change
2010-01-24 16:54 miqrogroove New Issue
2010-01-24 16:54 miqrogroove Status new => assigned
2010-01-24 16:54 miqrogroove Assigned To => miqrogroove
2010-01-24 16:59 miqrogroove File Added: ticket-342.patch
2010-01-24 18:59 miqrogroove SVN Revision => 2222
2010-01-24 18:59 miqrogroove Status assigned => resolved
2010-01-24 18:59 miqrogroove Fixed in Version => 1.9.11.08
2010-01-24 18:59 miqrogroove Resolution open => fixed
2010-02-24 17:57 miqrogroove Status resolved => closed