View Issue Details

IDProjectCategoryView StatusLast Update
0000498XMB1Bugspublic2017-03-15 09:27
Reportermiqrogroove 
Assigned Tomiqrogroove 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version1.9.8 SP3 
Target VersionFixed in Version 
Summary0000498: request_order INI Variable Added in PHP 5.3 May Disrupt Cookies
DescriptionSome or most versions of XMB relied on the $_REQUEST superglobal variable to retrieve cookies. That variable was provided by PHP until version 5.3. Starting with 5.3, an environment configuration change is required to use this feature. Without that change, the cookie system may not work at all.
Additional InformationSee http://php.net/ChangeLog-5.php

This variable is configured PERDIR, so the best solution for a patch is to drop use of $_REQUEST completely for backward and forward compatibility.
TagsNo tags attached.
MySQL Version
PHP Version5.4
Web Server
Browser
Flags
Original Reporterlottos
SVN Revision

Relationships

Activities

miqrogroove

2017-03-15 09:27

administrator   ~0000330

Bug was caused by reporter's code hacks and could not be duplicated in any version. XMB has never relied upon the $_REQUEST variable as its sole source of cookie data.

Issue History

Date Modified Username Field Change
2017-03-07 16:21 miqrogroove New Issue
2017-03-07 17:06 miqrogroove Status new => acknowledged
2017-03-07 17:06 miqrogroove Product Version => 1.9.8 SP3
2017-03-07 17:06 miqrogroove Additional Information Updated View Revisions
2017-03-15 09:27 miqrogroove Assigned To => miqrogroove
2017-03-15 09:27 miqrogroove Status acknowledged => closed
2017-03-15 09:27 miqrogroove Resolution open => unable to reproduce
2017-03-15 09:27 miqrogroove Note Added: 0000330